情系故鄉 / 指標 選股公式 / 通達信理想主圖優化版主圖源碼

0 0

   

通達信理想主圖優化版主圖源碼

2017-11-04  情系故鄉


B1:=REF(C,1);
 B2:=REF(C,2);
 SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0)))); 
 SM:=IF(REF(SS,1)!=0,REF(SS,1),IF(REF(SS,2)!=0,REF(SS,2),IF(REF(SS,3)!=0,REF(SS,3),IF(REF(SS,5)!=0,REF(SS,5),IF(REF(SS,6)!=0,REF(SS,6),IF(REF(SS,7)!=0,REF(SS,7),0))))));{股票公式網(www.gpgsw.com)為您整理} 
 STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,3,0),COLORRED; 
 STICKLINE(SS=2,B2,C,3,0),COLORRED; 
 STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,3,0),COLORRED; 
 VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
 VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
 VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
 VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
 {紅}
STICKLINE(C>O,C,O,3,0),COLOR000077;
 STICKLINE(C>O,C,O,2,0),COLOR000099;
 STICKLINE(C>O,C,O,1,0),COLOR0000BB;
 STICKLINE(C>O,H,L,0,0),COLOR0000FF;
 {綠}
STICKLINE(C<O,C,O,3,0),COLOR008000;
 STICKLINE(C<O,C,O,2,0),COLOR008000;
 STICKLINE(C<O,C,O,1,0),COLOR008000;
 STICKLINE(C<O,H,L,0,0),COLOR008000;
 TC1:=IF(H=HHV(H,8*14),H,DRAWNULL);
 TC2:=CONST(BARSLAST(TC1=H))+1;
 UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
 BC1:=IF(L=LLV(L,8*20),L,DRAWNULL);
 BC2:=CONST(BARSLAST(BC1=L))+1;
 LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
 LP:=CURRBARSCOUNT<=BC2 AND L=LOWER;{低點定位}
HP:=CURRBARSCOUNT<=TC2 AND H=UPPER;{高點定位};
STICKLINE(LP,L*0.992,L,13,0),COLORFF00FF;
 STICKLINE(HP,H,H*1.005,13,0),COLOR00FF00;
 X1:IF(CURRBARSCOUNT<=MAX(BC2,TC2),UPPER,DRAWNULL),COLOR89615F;
 X2:IF(CURRBARSCOUNT<=MAX(BC2,TC2),LOWER,DRAWNULL),COLOR89615F;
 X3:IF(CURRBARSCOUNT<=MAX(BC2,TC2),IF(BC2>TC2,UPPER-(UPPER-LOWER)*0.146,LOWER+(UPPER-LOWER)*0.146),DRAWNULL),COLOR89615F,NODRAW;
 X4:IF(CURRBARSCOUNT<=MAX(BC2,TC2),IF(BC2>TC2,UPPER-(UPPER-LOWER)*0.191,LOWER+(UPPER-LOWER)*0.191),DRAWNULL),COLOR89615F,NODRAW;
 X5:IF(CURRBARSCOUNT<=MAX(BC2,TC2),IF(BC2>TC2,UPPER-(UPPER-LOWER)*0.236,LOWER+(UPPER-LOWER)*0.236),DRAWNULL),COLOR89615F,NODRAW;
 X6:IF(CURRBARSCOUNT<=MAX(BC2,TC2),IF(BC2>TC2,UPPER-(UPPER-LOWER)*0.382,LOWER+(UPPER-LOWER)*0.382),DRAWNULL),COLOR89615F,NODRAW;
 X7:IF(CURRBARSCOUNT<=MAX(BC2,TC2),IF(BC2>TC2,UPPER-(UPPER-LOWER)*0.5,LOWER+(UPPER-LOWER)*0.5),DRAWNULL),COLOR89615F,NODRAW;
 X8:IF(CURRBARSCOUNT<=MAX(BC2,TC2),IF(BC2>TC2,UPPER-(UPPER-LOWER)*0.618,LOWER+(UPPER-LOWER)*0.618),DRAWNULL),COLOR89615F,NODRAW;
 X9:IF(CURRBARSCOUNT<=MAX(BC2,TC2),IF(BC2>TC2,UPPER-(UPPER-LOWER)*0.764,LOWER+(UPPER-LOWER)*0.764),DRAWNULL),COLOR89615F,NODRAW;
 X10:IF(CURRBARSCOUNT<=MAX(BC2,TC2),IF(BC2>TC2,UPPER-(UPPER-LOWER)*0.809,LOWER+(UPPER-LOWER)*0.809),DRAWNULL),COLOR89615F,NODRAW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X1,'高點')COLORRED;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X2,'低點')COLORYELLOW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X3,'0.146'),NODRAW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X4,'0.191'),NODRAW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X5,'0.236'),NODRAW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X6,'0.382'),NODRAW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X7,'0.5'),NODRAW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X8,'0.618'),NODRAW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X9,'0.764'),NODRAW;
 DRAWTEXT(CURRBARSCOUNT=MIN(BC2,TC2)+8,X10,'0.809'),NODRAW;
 CB1:=CONST(IF(TC2>BC2,LOWER,LLV(L,TC2))); 
 CB2:=CONST(BARSLAST(L=CB1)); 
 CB3:=CONST(REF(BARSLAST(O>C),CB2)+CB2); 
 CB4:=IF(CB1<UPPER-(UPPER-LOWER)*0.52,CONST(IF(CB2=0 AND O>C,C,REF(C,CB3))),DRAWNULL); 
 CB5:=IF(CAPITAL=0 AND BC2>TC2,CB4,DRAWNULL);
參考線:IF(CAPITAL=0 AND BC2>TC2 AND CURRBARSCOUNT<=INTPART(CB2+(TC2-CB2)*0.382) AND CURRBARSCOUNT>CB2,CB4,DRAWNULL); 
 DRAWTEXT(CURRBARSCOUNT=INTPART(CB2+(TC2-CB2)*0.382),參考線,'參考線'); 
確底線:參考線*1.06; 
 DRAWTEXT(CURRBARSCOUNT=INTPART(CB2+(TC2-CB2)*0.382),確底線,'確底線'); 
確防線:確底線*1.06; 
 DRAWTEXT(CURRBARSCOUNT=INTPART(CB2+(TC2-CB2)*0.382),確防線,'確防線'); 
DRAWTEXT(CURRBARSCOUNT=TC2-8 AND CB5>0,UPPER-(UPPER-LOWER)*0.091,'■確底線僅僅適用于指數'),COLOR3171D0; 
 DRAWTEXT(CURRBARSCOUNT=TC2-8 AND CB5>0,UPPER-(UPPER-LOWER)*0.151,'■請確認已跌去前一波大行情漲幅的百分之52以上'),COLOR3171D0; 
 DRAWTEXT(CURRBARSCOUNT=TC2-8 AND CB5>0,UPPER-(UPPER-LOWER)*0.208,'■跌幅不夠百分之52僅僅作為反彈看待而不是新底'),COLOR3171D0;
 DRAWICON(VAR19,(LOW * 0.98),11);
 DRAWICON(VAR1A,(H*1.01),12);
 DIR1:=ABS(CLOSE-REF(CLOSE,5));
 VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
 ER1:=DIR1/VIR1;
 CS1:=ER1*(0.8-2/8)+2/8;
 CQ1:=CS1*CS1;
 AMA1:EMA(DMA(CLOSE,CQ1),2) ,COLORWHITE;
 DIR2:=ABS(CLOSE-REF(CLOSE,10));
 VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
 ER2:=DIR2/VIR2;
 CS2:=ER2*(0.8-2/24)+2/24;
 CQ2:=CS2*CS2;
 AMA2:EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK2;
 AMA3:IF(AMA2/REF(AMA2,1)>0.997,AMA2,DRAWNULL),COLORYELLOW,LINETHICK2;
 AMA4:IF(AMA2/REF(AMA2,1)>1.001,AMA2,DRAWNULL),COLORRED,LINETHICK2;
理想主圖優化版主圖源碼

    本站是提供個人知識管理的網絡存儲空間,所有內容均由用戶發布,不代表本站觀點。如發現有害或侵權內容,請點擊這里 或 撥打24小時舉報電話:4000070609 與我們聯系。

    猜你喜歡

    0條評論

    發表

    請遵守用戶 評論公約

    類似文章 更多
    喜歡該文的人也喜歡 更多

    竞彩全包最牛技巧